ch
  • ch
  • Newbie Topic Starter
2014-08-13T21:58:18Z
I am getting an error ;-
Failed to create component 'iGrid' - 'System.Runtime,InteropService.COMException (0x804D745)'
A reference to the component 'TenTec.Windows.iGridLib.iGrid.v4.6' already exists in the project.

This error occurs when ever I try to place an iGrid control onto a form.

I removed the form on which I first noticed the problem, but that had no useful effect.
I have completely remove the reference to 'C:\10Tec\iGrid.NET 4.6\Bin\TenTec.Windows.iGridLib.iGrid.v4.6.dll' from the project and even uninstalled and reinstalled the iGrid demo and then the retail version.

The problem first started when the 'iGrid' icon disappeared from the toolbox. By trying to fix that I seem to have made things worse.
I know that it is something to do with my existing application as I can start a new solutions add the references and that works Ok.
I am using iGrid.NET version 4.6.5.0 and my application is being developed on
Visual Studios Professional 2013 Version 12.0.21005 REL.
.NET Framework version 4.5.50938
And I am using C# to do the coding.

So I have messed up somewhere but I can't find where.

So could you give me a step by step instructions for installing iGrid.NET please or is there a simpler solution. Or point me to where I can find that information please.

I have searched in the forum before creating this post

Thank you and sorry for the bother
Igor/10Tec
2014-08-14T07:38:50Z
It's definitely a problem of your particular project, but not iGrid.NET itself.

We have never faced this COM error while working with our control. I googled the problem and found a few similar cases - try the solutions from the following sources:

https://www.devexpress.c...Question/Details/Q256014 

http://www.telerik.com/f...adcontrols-with-designer 

http://social.msdn.micro...-reporting-windows-forms 

Let us know whether this helped.
ch
  • ch
  • Newbie Topic Starter
2014-08-15T10:07:48Z
Thank you.

After following on from your suggested links and following different leads I finally got it fixed. After many tries I finally produces this error message;-


Microsoft Visual Studio

No EditorOptionDefinition export found for the given option name: Tabs/ConvertTabsToSpaces

Parameter name: optionId

OK



I did some more searching for that error message on the internet and I arrived at this link

http://stackoverflow.com...ition-export-found-error 

I didn't keep a complete log as I was just experimenting with a trial & error approach so that is all I can tell you

When I followed that instruction it seems to have fixed my problem
As far as I can remember the last thing that I did before finding this solution was to begin over with my application. So I started a new project but then discovered that I could not get to 'View Code' and when I tried I got that 'EditorOptionDefinition' error and when I searched for that I got the above link in stackoverflow.

I followed the suggestion and renamed the 'ComponentModelCache' folder, in user account 'AppData\Local\Microsoft\VisualStudio\12.0\' and restarted VS2013 opened my application solution and my problem was solved.

I can now add iGrid controls again. It may have also to do with having a wrong reference to the iGrid that differed from the Toolbox version as I had removed all references to iGrid & TetTec from the application.

Possibly I muddied the waters so much in my search for a solution that my reply is not much use.

I am delighted, but I am sorry that I can't be more helpful. Thank you very much. I really appreciate your help.

Con