Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages<12
Options
Go to last post Go to first unread
AndyW  
#21 Posted : Tuesday, May 15, 2018 11:56:16 AM(UTC)
AndyW

Rank: Member

Groups: Registered
Joined: 4/30/2018(UTC)
Posts: 11
Location: Bristol

Thanks: 1 times
All I got was there were some cases raised regarding ActiveX issues and office. Told to wait a couple of weeks and check later builds to see if it is fixed!

Seems MS support can't raise an issue with the development team.

I created a simple Excel workbook with my form and the IGrid control. Build 9001.2138 it is fine, later builds it is not. Thought they might be interested if it was simple to reproduce.
AndyW  
#22 Posted : Wednesday, May 23, 2018 9:16:42 AM(UTC)
AndyW

Rank: Member

Groups: Registered
Joined: 4/30/2018(UTC)
Posts: 11
Location: Bristol

Thanks: 1 times
Just tried Build 1806 10211.20004, still not fixed
devwave  
#23 Posted : Thursday, May 24, 2018 3:05:44 PM(UTC)
devwave

Rank: Member

Groups: Registered
Joined: 4/4/2018(UTC)
Posts: 10

Was thanked: 3 time(s) in 1 post(s)
I managed to find another work around that may also shed light on the issue.


In the status bar of Microsoft Word there is a Display Settings option.

Apparently option only shows in status bar if it detects there’s a possibility for rendering issues:
Quote:
Note: The status bar will show a “Display Settings” indicator that appears whenever the app is in “Optimize for compatibility” mode, or whenever the app detects there’s a possibility for rendering issues. You can click that to quickly change between modes (app restart still required).



Setting this option to Optimize for compatibility fixes the issue and the control works as expected again.

The setting is also located in Word Options on the General tab under User Interface Options.

The label reads When using multiple displays: (both my test machines are using multiple displays but I haven't confirmed with clients if they are using multiple displays... maybe why not everyone can reproduce).


Office support for high definition displays:
https://support.office.c...S&rs=en-US&ad=US

While still not a fix... it's easier for clients to change setting than roll back office and may help narrow down the issue.

thanks 3 users thanked devwave for this useful post.
Igor/10Tec on 5/25/2018(UTC), AndyW on 5/30/2018(UTC), csmith222 on 2/20/2019(UTC)
AndyW  
#24 Posted : Thursday, May 24, 2018 3:25:18 PM(UTC)
AndyW

Rank: Member

Groups: Registered
Joined: 4/30/2018(UTC)
Posts: 11
Location: Bristol

Thanks: 1 times
This fixes the issue even if there is only a single monitor. My customer has a single monitor, my consultant with the issue is a single monitor but sometimes connected to another monitor. My test machine is a VM with a single monitor. Given it is set to optimize for best apperance and setting it to optimize for compatability fixes it, I wonder what it is doing as my application has some iGrids that work and others that don't.

Edited by user Thursday, May 24, 2018 3:47:18 PM(UTC)  | Reason: Not specified

AndyW  
#25 Posted : Wednesday, June 6, 2018 4:01:16 PM(UTC)
AndyW

Rank: Member

Groups: Registered
Joined: 4/30/2018(UTC)
Posts: 11
Location: Bristol

Thanks: 1 times
Just tried the June 1 Build 1806 10228.20021 update, still not fixed
Just tried the June 8 Build 1807 10301.20006 update, still not fixed

Edited by user Monday, June 11, 2018 12:09:08 PM(UTC)  | Reason: Not specified

Rodney  
#26 Posted : Thursday, November 8, 2018 11:12:36 AM(UTC)
Rodney

Rank: Newbie

Groups: Registered
Joined: 11/23/2016(UTC)
Posts: 1
Location: Den Haag

Thanks: 1 times
Hi All,

I have the same issue here. On a Multipage tab the iGrid is not visible when starting Word. When I run the form and do some actions and then close the form (hide) I go the the VBA Editor and click on the stop button in VBS. In Dutch it is called [Beginwaarden]. Then I start the form again and the iGrid is visible. STrange behaviour but when I close Microsoft Word and start it again I get the same issue and after the start of the form, doing some actions and hide the form and stop the code it works again. So Consistent behavior in my case but nothing that helps me find a solution for using it for my end-users. The fix devwave called in the Word options did the trick (thanx man).

Now we set the following registry key to make it work:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Word\Options]
"RenderForMonitorDpi"=dword:00000000


So where is the issue? In Microsoft Office or in the ocx? I don't know but the most important question is who can fix it permanently?
Igor/10Tec  
#27 Posted : Thursday, November 8, 2018 2:13:19 PM(UTC)
Igor/10Tec

Rank: Administration

Groups: Administrators, Forum Moderator
Joined: 1/17/2011(UTC)
Posts: 1,101

Thanks: 15 times
Was thanked: 141 time(s) in 141 post(s)
iGrid had worked in Microsoft Office flawlessly for years. This problem appeared only in one of the recent builds of Office this year, when Microsoft "enhanced" their Office suite to support high-DPI monitors better. As we understand the nature of the problem, Microsoft is trying to block OCX controls if they think the controls may not work properly on high DPI screens. It looks like an issue on their side, not in iGrid. At least, at the moment we do not know how to tell Word or Excel that our control must not be blocked in this scenario.
Igor/10Tec  
#28 Posted : Saturday, December 29, 2018 8:24:26 AM(UTC)
Igor/10Tec

Rank: Administration

Groups: Administrators, Forum Moderator
Joined: 1/17/2011(UTC)
Posts: 1,101

Thanks: 15 times
Was thanked: 141 time(s) in 141 post(s)
I have found other mentions of this issue:

https://www.add-in-expre....php?FID=5&TID=15006

http://kb.palisade.com/i....friendly&id=5#p1706

It turns out that the "Optimize for best appearance" feature affects not only ActiveX's but even other native Microsoft technologies like Windows Forms .NET.

Interesting, has something changed in the latest builds of Microsoft Office and they already fixed this problem? If you experienced this issue with iGrid ActiveX in Microsoft Office earlier, can you write some lines and tell us how things are now.
AndyW  
#29 Posted : Wednesday, January 2, 2019 11:36:00 AM(UTC)
AndyW

Rank: Member

Groups: Registered
Joined: 4/30/2018(UTC)
Posts: 11
Location: Bristol

Thanks: 1 times
I've just done an update to the latest Build 1901(11220.200008) and the issue appears to have been resolved.
devwave  
#30 Posted : Wednesday, January 2, 2019 2:30:00 PM(UTC)
devwave

Rank: Member

Groups: Registered
Joined: 4/4/2018(UTC)
Posts: 10

Was thanked: 3 time(s) in 1 post(s)
Originally Posted by: AndyW Go to Quoted Post
I've just done an update to the latest Build 1901(11220.200008) and the issue appears to have been resolved.


Don't have access to the version yet as a regular 365 subscriber. Looks like it went out to some office insiders and Microsoft Office 365 ProPlus users only so far.

No mention on 365 update page as of yet:
https://support.office.c...a-42c1-914f-bca4603e1426

So much for the the 365 description LOL:
Quote:
Office 365 is a subscription service that ensures you always have the most up-to-date modern productivity tools from Microsoft.
devwave  
#31 Posted : Saturday, January 5, 2019 1:34:34 AM(UTC)
devwave

Rank: Member

Groups: Registered
Joined: 4/4/2018(UTC)
Posts: 10

Was thanked: 3 time(s) in 1 post(s)
Microsoft Office 365 Business

Jan 04, 2019 Updated from 1811 to 1812 (11126.20188)

Still broken after 9 months.

Confirming again that it's never safe to update a Microsoft product. The tiny changes Microsoft Office makes to improve the software usually involves moving the same feature to another location so the user cannot find it! Having the most up to date version, which we obviously don't have anyway certainly doesn't seem worth the trouble, just so they can call it an update. They should concentrate on just updating the bugs.

Highly doubt any of our clients are getting updated to version 1901 either.
devwave  
#32 Posted : Tuesday, February 12, 2019 4:40:02 PM(UTC)
devwave

Rank: Member

Groups: Registered
Joined: 4/4/2018(UTC)
Posts: 10

Was thanked: 3 time(s) in 1 post(s)
Version 1901 (build 11231.20130)
Version 1901 (build 11231.20174)

Neither of the latest versions of 1901 fix the issue.

Control still fails to load unless switched to optimize for compatibility.
Juwelix  
#33 Posted : Tuesday, August 6, 2019 2:16:03 PM(UTC)
Juwelix

Rank: Newbie

Groups: Registered
Joined: 6/25/2019(UTC)
Posts: 3
Location: Solothurn

All my igrids are no longer displayed. I can see them (gray frame when clicking), but they are not visible.

I am using Office 365 16.0.11901.20070 32 - bit. What do I have to do to make the igrigs visible again?when_clickin draft mode.png
Igor/10Tec  
#34 Posted : Tuesday, August 6, 2019 3:47:59 PM(UTC)
Igor/10Tec

Rank: Administration

Groups: Administrators, Forum Moderator
Joined: 1/17/2011(UTC)
Posts: 1,101

Thanks: 15 times
Was thanked: 141 time(s) in 141 post(s)
Juwelix, have you tried to set the Optimize for compatibility option in the Word/Excel settings as it is described above?
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.