RaymondC
  • RaymondC
  • Advanced Member Topic Starter
2013-10-23T21:03:14Z
I have a big problem. My grid is not showing all the rows when I scroll down.

I use FillFromRS to populate the grid and my grid uses grouping. I check the RowCount property after the grid is populated and it correctly shows 697 rows but when I use the vertical scroll bar it does not go down all the way. Several hundred rows are missing.

I tried selecting the last row via code with: iGrid1.CurRow = iGrid1.RowCount but it doesn’t select anything. If I click on a column header and reveres the sort order then the “missing” rows are now visible on top but several hundred rows are still missing.

The grid seems to have all the data but has a limit on how many it can show?
RaymondC
  • RaymondC
  • Advanced Member Topic Starter
2013-10-23T21:23:43Z
Minutes after the previous post, I found the problem!

I use the AfterAutoGroupRowCreated event to format my group rows. I change the CellBackColor, set the CellValue, and increase the RowHeight so that my group rows are larger than my normal rows.

The RowHeight is what is causing the problem. If I comment out that single line then all the records show in the grid.

Is it possible to have a group row taller than a normal row?

Thanks.
Igor/10Tec
2013-10-24T12:28:08Z
Most likely, the question should sound like this: Is there a property to set the height of group rows created automatically?

When iGrid creates a new group row, it uses the value of the DefaultRowHeight property as the row height. Thus, it seems, you can solve your task by setting DefaultRowHeight to the required value after you populated the grid with normal rows, but before you call the Group method.
RaymondC
  • RaymondC
  • Advanced Member Topic Starter
2013-10-24T16:03:27Z
Excellent. That works great! Thanks again, Igor.