marzio
2020-09-23T21:03:32Z
on this code in designer.vb:
Me.IGAutoFilterManager1 = New TenTec.Windows.iGridLib.Filtering.iGAutoFilterManager()

I have this message
Errore BC30560 'iGAutoFilterManager' is ambiguous in namespaces 'TenTec.Windows.iGridLib.Filtering'.
I already removed from com objects the version 6 and now the only active
Igor/10Tec
2020-09-24T12:02:18Z
Most likely, you still have a reference to the v6.0 after upgrade to the v10.0. Try to clean the solution and remove all references to AutoFilterManager in your solution, then add a reference to the v10.0 again.

And does it happen only in one solution? Can you use the new AFM with iGrid.NET X in a brand new solution without that error?
marzio
2020-09-24T21:48:38Z
Very weird behaviour:
- no references of 6.0 version
- removed references of 10.0
- compiled and cleaned solution
- disinstalled autofilter 10.0 from finder
- reistalled autofilter 10.0
- opened project and inserted in form the autofilter object, and linked to the grid
- launched app
- no errors and grid loads but no filter shown !!
- when stopped the run , the same error B30560 !!
- on references , only 1 version of filter , the 10.0
autofilter.bmp

Click to View Image9 View(s)

Igor/10Tec
2020-09-25T14:33:39Z
Can you send us the full solution for the further consideration?

And have you tried to use AutoFilterManager v10 in a brand new solution as I suggested?
marzio
2020-09-26T18:08:29Z
On a new project it works
So I did some internet research and I found out that in solution explorer window under references I had both version 6 and version 10. So I removed there the reference to version 6 and now it works !! yea !!
Tommyworker
2020-10-02T14:56:45Z
Hello Marzio,
i had the same problem with new and old projects. So, my solution was to deinstall the complete version 6 and X and reinstall the latest version of demoversion of Igrid X. After reinstall you're selled your licenses from 10 Tec,
i rebootet the system. After this procudure i have no problems.
regards Thomas