Jeff
  • Jeff
  • Newbie Topic Starter
2022-05-06T11:10:56Z
I am currently running your current winforms iGrid control in C#. The grid is unbound and is being loaded from data coming from a SQL database and loaded into a list of objects. Each object's fields are strongly typed based on how those values are stored in the database.

The issue is, I have a customer number, which is typed as an Integer. When I sort the customer number column, it is sorting as text not numeric. How do I set the column type when defining the layout of the grid? What sort technique should I be using to ensure numbers are actually sorted as numbers?

Thank you for your help
Jeff
  • Jeff
  • Newbie Topic Starter
2022-05-06T11:17:07Z
I found the issue and the sort is now working correctly. I had incorrectly set the iGSortType setting.
Igor/10Tec
2022-05-07T04:57:43Z
It's hard to say what is wrong without seeing the whole application and source code, but most likely, your customer numbers come as strings to iGrid. If they were integers, you would not need to think about special sorting tricks at all. Check the type of customer numbers in iGrid.