• Troy
  • Newbie Topic Starter
For some reason, Igrid stopped working this morning. I logged on to my workstation and when I tried to load an Excel sheet with forms/grids, I got the "could not load an object because it is not available on this machine". I narrowed it down to Igrid, which, oddly enough, was working just find when I stopped working the previous evening.

I checked References and both the grid and image control were there, and selected. In the Toolbox, both tools where there. If I tried to drag the grid control to a form, it would give me an odd cursor (a "+" sign with a washed-out, undetermined icon) and then just sit there. After several attempts to get control back, i would get a "class not registered" error.

So I unchecked them from the References tool and delete them from the Toolbox. I then closed Excel, then using Regedit, I unregistered both OCX's. I then ran the reg.cmd command (where the OCX files are located). Both registrations were 'successful'.

I then opened Excel and then References... then browsed to the folder where the OCX files are and selected them. I then had to open the Toolbox and Add Additional Controls and select each one so they'd show in the Toolbox. When I drag either icon into the form, I get the "+" cursor with washed-out icon, then eventually get the "Class not registered" message.

Am I doing something wrong?