gkrish45
2018-12-11T21:51:08Z
Hi I am having issue in opening combobox,

i.e if i hit F4 the combobox dosen't open fully,

when i debug the items are there in combobox but wouldn't 0open, could you please help it is released in client already.


[edit]


My ?igrid1.Combos.Items(1).ListCount
1
AND
?igrid1.Combos.Items(2).ListCount
2

in immediate window, but the box just wouldn't open, could you tell me where i am going wrong.
Igor/10Tec
2018-12-12T14:48:00Z
Is this issue related to the problem discussed in this thread (opening a combo box list from code)? It seems not, and a new thread must be started.

Can you post an image demonstrating your problem?
gkrish45
2018-12-12T15:11:06Z
Here is the youtube link for the problem(demo)



Here is the exact code I use to populate the grid combobox

Private Sub DoCombos()
Dim strInvFilter As String
On Error GoTo Sub_EH: mstrStackTrace = mstrStackTrace & "." & "DoCombos"
'Create Dynamic combos for each row in the Pick Grid - Load combo with available Units
igrid1.Combos.Clear

For mlx = 1 To igrid1.Combos.Count
igrid1.Combos.Remove (mlx)
Next

For mlx = 1 To igrid1.RowCount

If "" <> GetRecord("Select TOP(1) 1 FROM tblInventory Where ICOMStype='" & igrid1.CellValue(mlx, "ICOMStype") & "' AND ICOMStype<>ICOMSNumber") Then

adorsInvNumber.Filter = "ICOMStype = '" & igrid1.CellValue(mlx, "ICOMStype") & "' AND Location =" & IIf(cjlAb <> "", "'" & cjlAb & "'", "'SLAB'") ''SLAB'"

With igrid1.Combos.add(igrid1.CellValue(mlx, "ICOMStype")) ' + CStr(igrid1.Combos.Count))
.AddItem " "
If adorsInvNumber.RecordCount > 0 Then
For y = 1 To adorsInvNumber.RecordCount
.AddItem adorsInvNumber!ICOMSNumber
adorsInvNumber.MoveNext
Next
End If
End With

DUPLICATE:
igrid1.CellType(mlx, "ICOMSNumber") = igCellCombo
igrid1.CellCtrlKey(mlx, "ICOMSNumber") = igrid1.CellText(mlx, "ICOMStype")

igrid1.ColDefaultCell("ICOMSNumber").eType = igCellCombo
igrid1.ColDefaultCell("ICOMSNumber").sCtrlKey = igrid1.CellValue(mlx, "ICOMStype")

End If
Next

Sub_Exit:
Exit Sub
Sub_EH:
If Err.Number = 457 Then
Resume DUPLICATE
End If
End Sub
Igor/10Tec
2018-12-12T15:35:02Z
It looks like your combo lists simply do not have items.

Are you sure you add some items in the following loop

If adorsInvNumber.RecordCount > 0 Then
   For y = 1 To adorsInvNumber.RecordCount
      .AddItem adorsInvNumber!ICOMSNumber
      adorsInvNumber.MoveNext
   Next
End If

?
gkrish45
2018-12-12T15:53:12Z
I am pretty sure, It has items

here is another video with debug, (shows it has items)



let me know if there some other way or order of steps to add items to combo, so it will open up
Igor/10Tec
2018-12-12T16:06:28Z
We need a sample to reproduce the problem. Can you create and send it to us?

We also sent you a private email in which we asked you to confirm your status of registered customer as we couldn't find your email in our registration database. Can you answer this question?
gkrish45
2018-12-12T16:13:36Z
I load combobox once in row 1

and then I clear the grid and combobox items and then load the grid again

this time with two more combobox items in two rows.

the two rows I add next are identical rows and has same set of combobox items


, this problem occurs, I'll try to complie a project for you. I need to ask my manager for email , id I'll confirm soon , also I'll see if there is a license key i can provide you
Igor/10Tec
2018-12-12T16:20:45Z
We need the registration email, company name and the person who purchased the product. It would be nice to see the order ID too.

Have you received our letter sent from the main domain (@10tec.com)? Let's continue the discussion of the registration question in email correspondence.
gkrish45
2018-12-12T16:28:40Z