Bob
  • Bob
  • Newbie Topic Starter
2015-01-13T13:23:42Z
We're evaluating the iGrid control for use in a 32 bit application (ProcessBook from OSIsoft) that supports VBA. After installing the iGrid Demo, we see the control, "10Tec iGrid Control 5.0", as a new item in the controls list. After adding the iGrid control to the display in the Designer, an object is placed on the display with a blue background. Inside the object is the text string, "10Tec iGrid Control 5.0" on one line and the text string, Symbol1" on the next line. The right click context menu shows the Properties item but it's disabled. In the VB Editor, Symbol1 does not show up in the Object drop down list. It acts as though it's a static object instead of a configurable control.

We tried this in MS Access 2007 and had no trouble adding and accessing the new control. This also worked fine in a VB 6.0 project.

Any thoughts on getting it to work in VBA? Or is this an indication that it's not going to work in this particular VBA development environment (ProcessBook is a 32 bit app using VBA 6.5)?

Thanks,

Bob
Bob attached the following image(s):
Igor/10Tec
2015-01-13T16:46:28Z
iGrid works ok in all Microsoft VB and VBA environments, and in a series of VBA compatible tools like AutoCAD. If you experience such an issue with iGrid in ProcessBook, this can be caused by one of the following 2 reasons:

1) ProcessBook does not support all features of the ActiveX technology.

2) iGrid should support some features specific for ProcessBook that make it possible to use iGrid as a control on its forms. For instance, it can be a COM interface ProcessBook uses to query what capabilities are supported by a control.

In either case you need to ask the OSIsoft support team about that. I believe they can tell what is wrong as they have access to the source code of their tool.
Bob
  • Bob
  • Newbie Topic Starter
2015-01-14T13:53:10Z
Igor
Thanks for the quick reply. We will do as you suggested.