• Lance
  • Newbie Topic Starter
Hi all,

Hoping someone will be able to help me with this one.

I am using iGrid 7.0 in FactoryTalk View SE on some userforms. One of my displays has 4 userforms associated with it that contain iGrid controls. When the page is displayed i get the following messagebox appear.


Click to View Image37 View(s)

If I remove the forms with iGrid I no longer get the messagebox appear, iGrid is the only activex component I am using. Is there a way I can add the iGrid OCX to a safelist or mark it as safe some how?
I am currently using the free demo version until I get this resolved, I'm not sure if this could be the problem?
This is definitely not the problem of the demo build. It may display nag screens or special watermark labels inside the control, but not this.

We have a similar problem with our ActiveX in Microsoft Office many years ago, but we solved it by implementing the special IObjectSafety interface in iGrid. We do not know whether FTV uses this feature or does it right. I would recommend that you contact the FTV developers and ask them about this.

And one more thing to check (just in case) is whether the OCX file is not marked as 'not safe' because it may come from the Internet zone. Open the file properties dialog. Do you see the Unblock button or checkbox on the first tab of the dialog? If yes, click/set it.

Keep us informed, please. This can help other customers using iGrid ActiveX in FTV.
  • Lance
  • Newbie Topic Starter
Hi Igor,

Thanks for your prompt reply, my apologies I have been tied up with other projects and haven't had a chance to look into this again until now.

There is nothing on the .OCX file properties about unblocking it, I have installed the certificates from the digital signatures tab but that hasn't helped


Click to View Image30 View(s)


Click to View Image30 View(s)


Click to View Image30 View(s)

Igor, could you please provide some information on the IObjectSafety interface as I am also having issues using igrid in FactoryTalk directly on a display. Rockwell wont help with VBA issues... 😞
I can't tell you much about this interface - more than this official documentation page contains: (v=vs.85)

It was enough to provide a basic implementation inside the interface's GetInterfaceSafetyOptions method to avoid displaying such a message in Microsoft Office. But I can't tell what is going on inside FTV.
  • Lance
  • Newbie Topic Starter
I have sorted part of my problems.

First I purchased the full version of the control. The version that came in the demo was version 700 and the version I received after purchasing was 750. So after changing all the references etc I had the same error :


Click to View Image28 View(s)

I then went through the properties of the .ocx file again, went to the digital signatures tab, click on an item in the signature list then the details button, View certificate, install certificate then repeat for the other item in the signature list.

On the security tab, I then clicked all application packages, clicked edit, and changed the permissions to allow for all options.

This got rid of the error I attached above.

I hope this helps someone in the future.