Bruno Montalvan
2014-06-04T00:37:49Z
I can't write decimal numbers with:

eTextEditOpt = igTextEditNumberOnly

What can I do?
Igor/10Tec
2014-06-04T14:29:59Z
Do you mean that you cannot type in the decimal point character? This is the expected behavior as the igTextEditNumberOnly flag implies that only numbers, i.e. characters from '0' to '9' are allowed.

If you need to enter the decimal separator, the minus sign, etc, you need to write your own cell editor by filtering the keyboard input. An example of that can be found in the main demo of iGrid - see the Property Grid sample.